View Issue Details

CategoryLast Update
[All Projects] RevOS - MIUI2019-03-07 11:42
ReporterinvitadoAssigned ToBadWolf 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Summary0000165: local and/or MI PC Suite backups/adb backups broken now (incomplete, many apps are not being backed up)
DescriptionSince Revolution OS 9.1.15 (since shifting to the Global base) the backup function is broken now.

Backups (without special tools like Titanium Backup) are quite useless now because only a fraction of the apps and app data are being backed up now!

This is obviously related to apps with the android directive "allowbackup=false". All these apps can no longer be backed up, this means:

- "local backup and restore" only backs up about half (in my case) of all the applications installed; all the other apps are missing in the list of apps backed up (there are no 0 byte files here, they are just missing, not present in the files backed up)

- backups via MI PC Suite (also called: MI Phone Assistant) suffer from the same issue: Only a fraction of all the apps and data are being backed up; all the other apps result in 0 bytes files (*.bak with 0 bytes)

- MI Cloud backups: same issue

- adb backups: same issue
Steps To Reproduce- use Revolution OS 9.1.15 (alternatively: any global rom, any xiaomi.eu rom)
- try to backup your system (backup&restore - or - cloud backup - or - MI PC suite backup - or - simple adb backup

Test it with apps that are always backed up and such apps that are never backed up now:

For instance:
- Backups of Opera Mini work
- Backups of the normal Opera Browser do not work

Other examples:
- Backups of Skype, Telegram, Whatsapp, Outlook DO NOT work
- Backups of Kodi, OruxMaps (spanish navigation app), MyDrive, Open Camera WORK
Additional InformationWhen starting a local backup there is also a warning message telling me that maybe not all apps will be backed up!

Obviously, the system tells us that some apps are not allowed to be backed up (because the android directive allowbackup=false is set)

There is no such warning and no such issue in China based roms.
DeviceMy device: Redmi Note 4 snapdragon

But this issue is not specific to this device, but instead, it is specific to non-China based roms.
Telegram UserFred

Activities

invitado

2019-02-04 02:13

viewer   ~0000173

I have to correct my bug report.

adb backups of apps that are not allowed to be backed up (like "opera browser", in contrast to "opera mini" which is allowed to be backed up) do NOT work in global roms AND they do NOT work in China roms.

So the topic of this bug report should be:
local and/or MI PC Suite backups are broken now (incomplete, many apps are not being backed up)

What works in official China roms as well as in truly China based roms (revos 8.12.6, miuipro) are local backups and MI PC Suite backups (ergo: backups with the official Xiaomi provided tools!).


These backups no longer work in global roms, xiaomi.eu roms, revos 9.1.15.

"not working" means:

local and/or MI PC Suite backups do start and really work for a lot of apps, but by far not all apps!
Moreover, when launching such a local backup you get a message (that you do not get in the China or China based roms!):
"backups may not work".

And apps that are disallowed to be backed up give a message: "not supported"

I would really like the new Revolution OS version in February 2019 to resolve this issue, but, honestly, I wouldn't hold my breath. :-(
xiaomi.eu seems to be unable or unwilling to solve this issue either - and in fact, by the way, this makes me believe that xiaomi.eu is cheating when saying that it is China based - but okay, this doesn't really belong in a bug report.

Fred

Issue History

Date Modified Username Field Change
2019-01-18 17:14 invitado New Issue
2019-02-04 02:13 invitado Note Added: 0000173
2019-03-07 11:42 BadWolf Assigned To => BadWolf
2019-03-07 11:42 BadWolf Status new => closed
2019-03-07 11:42 BadWolf Resolution open => fixed
2019-09-04 15:38 BadWolf Category Revolution OS - MIUI => RevOS - MIUI